Model disappearance in game.

Model disappearance in game.

Postby Class1987 » Sat Aug 01, 2020 9:01 pm

Hi everyone has anybody had issues with some parts of an exported model suddenly disappear when getting close to it? I thought it was just world editor being silly so went into play mode and the same is happening there. I've named the pieces in 3ds max 1_1000_xxxx so can't be anything to do with that, plus I've actually attached all the objects into one full model and I still get the same issue, any advice? Cheers, Ian.
Class1987
Full Time Fireman
 
Posts: 77
Joined: Thu Jun 16, 2016 12:40 am
Has thanked: 0 time
Been thanked: 3 times

Re: Model disappearance in game.

Postby eyore » Sun Aug 02, 2020 9:45 am

Check the pivot has the right orientation and if that's ok then try "Reset Xform".
Phil

Image
User avatar
eyore
Passed Fireman
 
Posts: 136
Images: 12
Joined: Tue Apr 01, 2014 6:34 pm
Location: Lake District
Has thanked: 25 times
Been thanked: 66 times

Re: Model disappearance in game.

Postby Class1987 » Sun Aug 02, 2020 1:07 pm

Thanks Phil I’ll give it a try.
Class1987
Full Time Fireman
 
Posts: 77
Joined: Thu Jun 16, 2016 12:40 am
Has thanked: 0 time
Been thanked: 3 times

Re: Model disappearance in game.

Postby AndiS » Sun Aug 02, 2020 7:07 pm

The usual recommendation is also to reset scaling, rotation and origin. This last one most of all.
I noticed this when the offset was way out. Things disappear when their origin it off screen (and their bounding box too?).
AndiS
Top Link Driver!
 
Posts: 665
Joined: Wed Apr 09, 2014 5:48 pm
Has thanked: 267 times
Been thanked: 306 times

Re: Model disappearance in game.

Postby Class1987 » Tue Aug 04, 2020 6:11 pm

The reset Xform worked, thanks guys much appreciated.
Class1987
Full Time Fireman
 
Posts: 77
Joined: Thu Jun 16, 2016 12:40 am
Has thanked: 0 time
Been thanked: 3 times


Return to 3DS Max

Who is online

Users browsing this forum: No registered users and 0 guests

cron